Commit 0dfdc922 authored by Fabian Galinski's avatar Fabian Galinski

[BUGFIX] An error appears, if the tinymce is selected as editor

parent 34472062
......@@ -28,6 +28,7 @@ namespace SGalinski\Lfeditor\Controller;
use SGalinski\Lfeditor\Exceptions\LFException;
use SGalinski\Lfeditor\Session\PhpSession;
use SGalinski\Tinymce\Loader;
use TYPO3\CMS\Core\Cache\CacheManager;
use TYPO3\CMS\Core\Messaging\AbstractMessage;
use TYPO3\CMS\Core\Page\PageRenderer;
......@@ -279,7 +280,7 @@ abstract class AbstractController extends ActionController {
}
$pathTinyMCEConfig = PATH_site . ExtensionManagementUtility::siteRelPath('lfeditor')
. 'Resources/Public/Scripts/TinyMCEConfig.js';
$tinyMCE = $this->objectManager->get('\SGalinski\Tinymce\Loader');
$tinyMCE = $this->objectManager->get(Loader::class);
$tinyMCE->loadConfiguration($pathTinyMCEConfig);
/** @var PageRenderer $pageRenderer */
......
......@@ -4,7 +4,7 @@
"description": "Language File Editor",
"homepage": "https://www.sgalinski.de",
"license": ["GPL-2.0+"],
"version": "3.2.0",
"version": "3.3.1",
"support": {
"issues": "https://forge.typo3.org/projects/extension-lfeditor"
},
......
......@@ -29,7 +29,7 @@ Following functions are implemented in this module:
* Backups, recovering and diff view',
'category' => 'module',
'shy' => 0,
'version' => '3.3.0',
'version' => '3.3.1',
'doNotLoadInFE' => 1,
'dependencies' => '',
'conflicts' => '',
......@@ -55,7 +55,7 @@ Following functions are implemented in this module:
'conflicts' => array(
),
'suggests' => array(
'tinymce' => '4.2.0',
'tinymce' => '4.2.8',
),
),
'suggests' => array(
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment